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General 
· Where can I find the latest information on Medi-Gate?
· Where can I get the latest version of the Medi-Gate Software?
· How does the Medi-Gate Integrator work?
· How do templates work? 
· How do I determine the name and version of a PMS system?
· Will Medi-Gate work with Netscape?
· Can I use Medi-Gate with a UNIX-based system?
Hardware & Software Requirements

· What are the supported operating systems?
· What are the Medi-Gate client workstation hardware requirements?
· What are the Medi-Gate software requirements?
· How do I determine the version of Internet Explorer installed?
· What is the .NET Framework?
· How do I determine if the .NET Framework is installed?
Installing the Integrator

· There is not a Medi-Gate installation guide for Windows ME, what do I need to do to install Medi-Gate on a Windows ME machine?
· Can I install Medi-Gate on a Windows 95 machine?
· How do I install the .NET Framework?
· What will happen if I do not load the .NET Framework?
· The customer does not have Internet Explorer 5.01 or higher, what should I do?
· What are the general steps for installing Medi-Gate on Win2000, XP, NT, and Win 98?
· Where do I enter the Org ID, username, and password? 
· How do I know which print drivers to install?
· I am getting a message that says “Microsoft Installer needs to update my install program is this ok?”; however, when I click Yes to proceed, I get an error message saying I am missing a Microsoft Installer component. What can I do? 

Reports

· What type of report information should I be looking for?
· What are the best reports to run?
· What type of link am I supposed to look for between reports?
Sending a Test
· I am getting an error when trying to print to the Medi-Gate driver. What should I do?
· How do I print to an output file? 
· How do I send an output file manually?
· When I go to print a report, Medi-Gate opens over and over again. What is happening?
· How do I know if I have successfully transmitted test files?
· I am getting a “There are no files available to send error” when trying to send a test. What is happening?
· I am getting the following error trying to send a test: “There was an error writing to RPT1: for the printer Medigate. The printer command is invalid. What should I do?
· I am getting a very long error trying to send a test. The error starts out talking referencing System.Web.Services.Protocols and eventually talks about Procedure Logon expects parameter @password. What should I do?
Changes to FAQ (list dates) 
· 05/21/2003
· 07/02/2003
· 07/08/2003
Top

General
Where can I find the latest information on Medi-Gate? 
The most current information on Medi-Gate can be found in the Medi-Gate Bridge Implementation section of the eMaxx Customer Center. To access this site:

1. Navigate to the following website: http://www.medplus.com/tech-support/tech-support.htm.

2. Click the eMaxx link.

3. Enter your user name and password.

· If you are unsure of the user name and password, contact your Medi-Gate business unit champion or Medplus support.

4. Click the Medi-Gate Bridge Implementation link.
· Click the appropriate links to access required information.
 Return
Where can I get the latest version of the Medi-Gate software?

Access the Medi-Gate Bridge Implementation section of the eMaxx Customer Center. To do this, use the following instructions:

1. Navigate to the following website: http://www.medplus.com/tech-support/tech-support.htm.

2. Click the eMaxx link.

3. Enter your user name and password.

· If you are unsure of the user name and password, contact your Medi-Gate business unit champion or Medplus support.

4. Click the Medi-Gate Bridge Implementation link.

5. Click the Installation Files link.

6. Follow the instruction on the download page to download the latest version. Return
How does the Medi-Gate Integrator work?

The Medi-Gate Integrator™ software allows a customer to send patient demographic and insurance information from their practice management system via a secure internet connection to the TOROL or LabPortal applications so that customers need not re-key patient data when ordering lab tests on-line. Return
How do templates work?

Once report templates have been created and tested for the customer’s practice management system, they are then uploaded from the development site to the production server client site. Once a customer site is activated, report information incoming from the customer’s practice management system is directed through the templates and filtered so that only the pertinent patient demographic and insurance information that is required to process online labs in TOROL or LabPortal is collected. Return
How do I determine the name and version of a PMS system?

For most Windows-based PMS systems, you can click the Help menu and then select the About option. This should list the PMS name and version. Return
Will Medi-Gate work with Netscape?

No. Medi-Gate only works with Windows Internet Explorer 5.01 or higher. Return
Can I use Medi-Gate with a UNIX-based system?

This depends. The key things to look at are the following: 
· Is the UNIX system running under a terminal emulator – that is, can the UNIX program can be accessed from a Windows workstation. If so, then you may be able to use Medi-Gate.

· Next, can the Integrator part of the program be installed on a Windows workstation and is an internet connection present on that workstation? If yes then, you may be able to use Medi-Gate. 
· Next, can you print reports from the PMS (running in UNIX) to a Windows print driver (the Medi-Gate drivers)? For example, if you load a Medi-Gate print driver, can you access that driver from the PMS? If yes, then you can probably use Medi-Gate. If no, then you need to determine if you can print reports to output files.

· Can you print reports to output files? If you can’t print to a Windows print driver, can the PMS print to a disk file or output file? If so, you can then use the integrator to send this file manually. For more information on sending files manually, refer to the Manual File Send procedure. Return
Hardware & Software Requirements

What are the supported operating systems?
· Windows 98 (second edition required)
· Windows ME

· Windows NT 4.0 (service pack 6a required)

· Windows 2000 (service pack 2 recommended)

· Windows XP   

 Return
What are the Medi-Gate client workstation hardware requirements?
· Pentium 90 MHz or above

· 32 MB RAM (96 MB recommended)

· 150 MB free disk space

· Resolution of 800x600, 256 colors   

Return
What are the Medi-Gate software requirements?
· Internet Explorer 5.01 or higher

· Microsoft .NET Framework   
Return
How do I determine the version of Internet Explorer installed?

Launch the internet browser, and then select About Internet Explorer from the Help menu. The version of Internet Explorer will be displayed. Return
What is the .NET Framework?

The .NET Framework is Microsoft Windows’ component for building and running web applications. Medi-Gate takes advantage of this framework; therefore, a customer’s machine must have this framework installed. Return
How do I determine if the .NET Framework is installed?

Access the computer’s control panel, and then select the Add/Remove programs option. Check the resulting list for the Microsoft .NET Framework. For more detailed information on this process, consult the Medi-Gate Integrator installation guides. Return
Installing the Integrator

There is not a Medi-Gate installation guide for Windows ME, what do I need to do to install Medi-Gate on a Windows ME machine?
Use the Windows 98 installation guide for a Windows ME installation. Return
Can I install Medi-Gate on a Windows 95 machine?
Windows 95 is not a supported operating system (Windows 95 cannot support the .NET Framework). Return
How do I install the .NET Framework?
To install the framework, simply double-click the dotnetfx.exe file and follow the prompts. For more detailed information on installing the .NET Framework, refer to Appendix B of the installation guide.

If you do not have a copy of the .NET Framework, you can download it from the Medi-Gate Bridge Implementation section of the eMaxx Customer Center. To do this, 
1. Navigate to the following website: http://www.medplus.com/tech-support/tech-support.htm
2. Click the eMaxx link

3. Enter your user name and password

4. Click the Medi-Gate Bridge Implementation link

5. Click the Installation Files link

6. Follow the instructions on the download page to download the latest version of the .NET Framework. 

It is important to note, installers should download the latest version of the .NET Framework and Medi-Gate Integrator and burn them to a CD before installing a customer. Since these files are quite large (11 and 20 MBs), waiting to download while at the customer site may take a long period of time. Return
What will happen if I do not load the .NET Framework?
If you do not load the .NET Framework, you will get an error message when installing the Integrator informing you that the .NET Framework must be installed. Return
The customer does not have Internet Explorer 5.01 or higher, what should I do?

You need to have the customer upgrade to a newer version of Internet Explorer on the workstation you are installing Medi-Gate. Later versions of Microsoft Internet Explorer can be found at Microsoft’s website. Return
What are the general steps for installing Medi-Gate on Win2000, XP, NT, and Win 98?

The overall steps are as follows:

· Step 1 – Verify System Requirements

· Step 2 – Verify Software Requirements

· Step 3 – Install the Medi-Gate Integrator™
· Step 4 – Configure the Medi-Gate Integrator™

· Step 5 – Install the Re-direction Port Monitor
· Step 6 – Install the Generic PostScript Driver

· Step 7 – Install any other Medi-Gate Drivers required

· Step 8 – Configure the Medi-Gate Print Drivers

· Step 9 – Transmit Report Information to Medi-Gate
For detailed information on these steps, refer to the installation guides for Windows 2000/XP, Windows 98, and Windows NT. Return
Where do I enter the organization ID (Org ID), username, and password?
The OrgID, username, and password are entered in the setup screen of the Medi-Gate Integrator. To access this screen, launch the Integrator from the Windows Desktop and then select Setup from the File menu. From the Setup screen, enter the orgID, username, and password in the appropriate fields. For more detailed information on this process, refer to the Medi-Gate Installation guide. Return
How do I know which print drivers to install?
Separately from installing the Medi-Gate Integrator™ software, you need to install the proper Medi-Gate Windows™ print driver(s).  The Medi-Gate print drivers are used to send report information from the practice management system, such as a patient face sheet, to the Medi-Gate server where specific information is then extracted from the report and formatted for either TOROL or LabPortal.  

Depending on the number of reports that must be used to extract patient demographic and insurance information, you may need to install more than one print driver.  

If patient demographic and insurance information is contained in one report, then you only need to install the Medi-Gate bpatdemoins (batch demographic + insurance) driver. 

If the information is contained in two separate reports (one for patient demographic information and one for patient insurance information), and the reports can either be for one or more patients then use the patdemo and the patins drivers.

For more detailed information on installing Medi-Gate print drivers, refer to the Medi-Gate installation guides for the appropriate operating system. Return
I am getting a message that says “Microsoft Installer needs to update my install program is this ok?” However, when I click Yes to proceed, I get an error message saying I am missing a Microsoft Installer component. What can I do?

You might get this message if you are installing Medi-Gate on a Windows 98 operating system that is not the second edition. If you get this error, you will need to download a copy of Microsoft installer from their website and install it before you can continue. Return
General Reports

What type of report information should I be looking for?

For online lab services, patient demographic and related insurance plan information are the key pieces of information for which we are looking. Demographic information needed includes patient name, address, phone numbers, social security number, gender, birth date, and patient ID or account number. Insurance information includes patient ID and or account number, insurance name, group and policy numbers, address information if possible, relationship to insured and information on the insured party (at least a name). Return
What are the best reports to run?

If at all possible, look for a patient face sheet or chart cover report that can be run in batch (for multiple patients). This type of report usually includes all of the information we are looking for. Return
What type of link am I supposed to look for between reports?
If the information required is found in two reports, you need to look for a unique patient identifier that is common between reports. Unique identifiers almost always are a patient account or ID number, or social security number (it must appear in both reports). It allows us to tie information from one patient report to the information contained in another patient report. Return
Sending a Test

I am getting an error when trying to print to the Medi-Gate driver. What should I do?

Check to see that the user trying to print has rights to the Medi-Gate software. This problem may occur on Windows operating systems that allow for multiple user profiles (Windows 2000, Windows XP, and Windows NT). When the integrator is installed on these systems, the installer must have administrative rights and install the application for all users. Return
How do I print to an output file? 

You may need to use this process when you can’t print to a Medi-Gate driver (typically happens when the practice management system is UNIX or DOS-based). The actual procedure used to do this depends on the practice management system encountered. Some PMSs have an option that allows printing to an output file. If the practice management system has this option, then you can print the reports identified to the appropriate output file. Make sure you note the name and path to which the files are printed because you will need to locate these files and send them manually through the integrator. For information on sending these output files to Medi-Gate, refer to the Manual File Send procedure. Return
How do I send an output file manually?

After you have created an output file (printed reports to a file), you need to open the MGI application on the Windows Desktop and access the Setup screen (File>Setup). From the Setup screen, click the Transmit tab and adjust the Patient Demographics and Patient Insurance path and/or Batch Patient Demographic and Patient Insurance path and files names accordingly, and then click Save (Note: If you used one report for both demographic and insurance information, point the Patient Demographic and Patient Insurance path to the same file). You only need to change the path and file names once (assuming you always print the output file to the same location and use the same name).
The next step is to transmit the information. To do this, select File>Transmit. For more information on transmitting a file manually, refer to the Manual File Send procedure.  Return
When I go to print a report, Medi-Gate opens over and over again. What is happening?

If this situation is occurring, the most likely reason is that the report you have selected is sending each patient record, or page of the report, to the print driver as a separate print job. If this happens, you will need to either find a new report(s) that do not do this, or try printing the report to an output file (if the output file option creates multiple output files as well, then this is not a solution). If none of this works, just send one patient worth of information. The customer will then need to be trained to send just one patient at a time. The best way to do this would be to send the information as soon as a patient has checked in (as part of the check in process). If this is the process that must be used, the integrator will need to be installed on those workstations that are used to check patients in (remember, they must have an internet connection). Return
How do I know if I have successfully transmitted test files?

The integrator will open after the files have been printed to the Medi-Gate driver, you will then see at the bottom of the Integrator a series of messages, including: Compressing patient demographics, Transmitting patient demographics, Compressing patient insurance, and Transmitting patient insurance. Once the integrator is done sending (at the end of transmitting patient insurance information), it will close automatically (unless you are doing a manual file send). This indicates the test has been sent successfully. Return
I am getting a “There are no files available to send error” when trying to send a test. What is happening?
This message appears when Medi-Gate can’t find the file to send that gets created as a result of printing a PMS report. Usually this happens when the driver program name was incorrectly entered (spelled wrong) when setting up the printer driver. To check to see if you have the driver names correct use the following instructions:
For Win XP, 2000, & NT

1. Access the Printers window.

2. Right-click the appropriate Medi-Gate printer and select properties.

3. Click the Ports tab.

4. Click Configure Port.

5. In the “Arguments for this program are” field, verify that the name after Auto is spelled correctly (use the list below – only use one):

· patdemoins

· patdemo

· patins

· bpatdemoins

· bpatdemo

· bpatins

Win98

1. Access the Printers window.

2. Right-click the appropriate Medi-Gate printer and select properties.

3. Click the Details tab

4. Click the Port Settings button

5. In the “Arguments for this program are” field, verify that the name after Auto is spelled correctly (use the list below – only use one):

· patdemoins

· patdemo

· patins

· bpatdemoins

· bpatdemo

· bpatins

Return
I am getting the following error trying to send a test: “There was an error writing to RPT1: for the printer Medigate. The printer command is invalid.” What should I do?

This error occurs on Windows 98 installations when the spool settings for the Medi-Gate printer port have not been configured correctly. To correct, use the following procedure:
1. Access the Printers window.

2. Right-click the appropriate Medi-Gate printer and select properties.

3. Click the Details tab.

4. Click the Spool Settings button.

5. Click the “Disable bi-directional support for this printer” radio button. 

6. Click OK.

7. Click OK.

Return
I am getting a very long error trying to send a test. The error starts out referencing System.Web.Services.Protocols and eventually says that Procedure Logon expects parameter @password. What should I do?

This error occurs when you enter the password assigned to the customer in the Group field of the Medi-Gate integrator setup screen instead of the Password field. To fix this error:

1. Double-click the MGI.NET icon to launch the Medi-Gate Integrator.

2. From the Menu bar, select the following menu options: File>Setup.

3. Delete the information in the Group field (this field should be blank).

4. Enter the password assigned to the customer in the Password field.

5. Click Save.

6. Exit the Integrator.

7. Re-send your test.

Return
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